nixos-config/variable.nix
2025-01-17 20:19:21 +01:00

25 lines
540 B
Nix

{ config, ... }:
{
config.var = {
hostname = "garnix";
username = "remy";
configDirectory = "/home/" + config.var.username
+ "/.config/nixos"; # The path of the nixos configuration directory
keyboardLayout = "de";
location = "Berlin";
timeZone = "Europe/Berlin";
defaultLocale = "en_US.UTF-8";
extraLocale = "de_DE.UTF-8";
git = {
username = "Hadi";
email = "112569860+anotherhadi@users.noreply.github.com";
};
autoUpgrade = false;
autoGarbageCollector = true;
};
}